For direct access use https://forums.oldunreal.com
It's been quite a while since oldunreal had an overhaul, but we are moving to another server which require some updates and changes. The biggest change is the migration of our old reliable YaBB forum to phpBB. This system expects you to login with your username and old password known from YaBB.
If you experience any problems there is also the usual "password forgotten" function. Don't forget to clear your browser cache!
If you have any further concerns feel free to contact me: Smirftsch@oldunreal.com

FreeBSD

Report bugs, read about fixes, new features and ask questions about the Unreal 227 patch here. Place comments and commit suggestions.
Post Reply
User avatar
x21
OldUnreal Member
Posts: 71
Joined: Thu Mar 30, 2017 3:13 pm

FreeBSD

Post by x21 »

Hello All;

I am wondering if anyone has had luck running Unreal under FreeBSD.

x21
ImageImageImage
User avatar
tlk
OldUnreal Member
Posts: 37
Joined: Fri May 08, 2020 6:24 am

Re: FreeBSD

Post by tlk »

Simple answer: nag the devs to compile for your OS of choice.
Probability of success: slight.
User avatar
[]KAOS[]Casey
OldUnreal Member
Posts: 4385
Joined: Sun Aug 07, 2011 4:22 am
Location: over there

Re: FreeBSD

Post by []KAOS[]Casey »

honestly there's a good chance it's not even allowed under the terms, it may specifically call out linux being allowable. gotta love contracts.
User avatar
anth
Administrator
Posts: 335
Joined: Sat Oct 17, 2009 6:31 pm

Re: FreeBSD

Post by anth »

Have you actually tried this? FreeBSD should be able to run the 227 Linux client. Installing all of the dependencies might be challenging, though.
User avatar
x21
OldUnreal Member
Posts: 71
Joined: Thu Mar 30, 2017 3:13 pm

Re: FreeBSD

Post by x21 »

Does anyone know what dependencies there are?
User avatar
[]KAOS[]Casey
OldUnreal Member
Posts: 4385
Joined: Sun Aug 07, 2011 4:22 am
Location: over there

Re: FreeBSD

Post by []KAOS[]Casey »

https://docs.freebsd.org/en_US.ISO8859- ... stall.html

seems like freebsd has a linux compatability layer. looks like the tl;dr here is that you could take a working i386 install of linux + unreal and copy the dependencies over to freebsd and it might work
User avatar
x21
OldUnreal Member
Posts: 71
Joined: Thu Mar 30, 2017 3:13 pm

Re: FreeBSD

Post by x21 »

[]KAOS[]Casey wrote: Tue Feb 09, 2021 4:39 am https://docs.freebsd.org/en_US.ISO8859- ... stall.html

seems like freebsd has a linux compatability layer. looks like the tl;dr here is that you could take a working i386 install of linux + unreal and copy the dependencies over to freebsd and it might work
Dependencies are unclear. I am sure bsd can possibly run it. Copying binaries over might not be a good idea unless I run a jail.
User avatar
Smirftsch
Administrator
Posts: 8784
Joined: Wed Apr 29, 1998 10:00 pm

Re: FreeBSD

Post by Smirftsch »

m, pthread, dl, everything else should be included like libxmp, sdl2, openal, ogg, flac, vorbis etc.
Sometimes you have to lose a fight to win the war.
User avatar
[]KAOS[]Casey
OldUnreal Member
Posts: 4385
Joined: Sun Aug 07, 2011 4:22 am
Location: over there

Re: FreeBSD

Post by []KAOS[]Casey »

x21 wrote: Wed Feb 10, 2021 6:50 am Dependencies are unclear.
false.
ldd *.so and ldd *.bin will show you the dependencies.

freebsd documentation even shows this (which would reveal a dependency tree from UCCLinux.bin to the .so files)
image.png
image.png (11.71 KiB) Viewed 345 times
User avatar
x21
OldUnreal Member
Posts: 71
Joined: Thu Mar 30, 2017 3:13 pm

Re: FreeBSD

Post by x21 »

Smirftsch wrote: Wed Feb 10, 2021 7:40 am m, pthread, dl, everything else should be included like libxmp, sdl2, openal, ogg, flac, vorbis etc.
thx thumbsup

[]KAOS[]Casey wrote: Thu Feb 11, 2021 4:24 am false.
ldd *.so and ldd *.bin will show you the dependencies.

freebsd documentation even shows this (which would reveal a dependency tree from UCCLinux.bin to the .so files)
I must have missed that. Thank you for your help.
User avatar
tlk
OldUnreal Member
Posts: 37
Joined: Fri May 08, 2020 6:24 am

Re: FreeBSD

Post by tlk »

x21 wrote: Mon Feb 08, 2021 7:56 pm Does anyone know what dependencies there are?
runs a BSD on a desktop/SOHO server
c00l l33t haxx0r
can't into ldd (or whatever BSD has)
typical
User avatar
tlk
OldUnreal Member
Posts: 37
Joined: Fri May 08, 2020 6:24 am

Re: FreeBSD

Post by tlk »

[]KAOS[]Casey wrote: Tue Feb 09, 2021 4:39 am https://docs.freebsd.org/en_US.ISO8859- ... stall.html

seems like freebsd has a linux compatability layer. looks like the tl;dr here is that you could take a working i386 install of linux + unreal and copy the dependencies over to freebsd and it might work
yeah some sort of a binary compat layer has been there for like ages.
the best compat layer tho would be to install Linux and get on with it.
User avatar
tlk
OldUnreal Member
Posts: 37
Joined: Fri May 08, 2020 6:24 am

Re: FreeBSD

Post by tlk »

[]KAOS[]Casey wrote: Sat Feb 06, 2021 3:31 am honestly there's a good chance it's not even allowed under the terms, it may specifically call out linux being allowable. gotta love contracts.
why there's no score (+/-) in the new shiny forum engine
Post Reply

Return to “Unreal 227”